Jump to content

Ubiquiti home networking - initial impressions


Recommended Posts

So following much umming and ahhing (detailed here), and lots of advice from @joth , @JonJumpand @Thorfun and others, I took the plunge and bought a Ubiquiti Dream Machine and two IWHD access points. All three components are compatible with the Wifi6 standard, which doesn’t make much difference now, but hopefully will do when we upgrade phones etc. I see that the new fire stick supports wifi 6 also, but haven’t got one of those.

 

I wanted to get a switch as well, but they are all sold out, and as advocated by  @Nickfromwales, the IWHD actually have a built in switch for four ports, one of which is PoE pass through so temporarily I’m managing without a separate switch.

 

I went with the UDR over the UDR pro because at £185 it is considerably cheaper and has a built in access point. I also don’t need the extra functionality of the pro.

 

 Managed to turn off the wifi and the DHCP server on the Virgin super hub. Plugged that in to the UDR and then set that up which was straight forward enough with just one network. Used the same SSID and pw as my old Virgin Network so that I wouldn’t have to change credentials on all my devices.

 

Then I plugged in and provisioned the two IWHD APs using the two PoE ports on the UDR. One AP provisioned pretty easily. For reasons I don’t understand, the other was more temperamental, though appears to have settled down after I rebooted it and tried again.

 

The major problem we are having is our Ring doorbell and Amazon fire stick are not happy, despite the Unifi app thinking they are both having a great “wifi experience” score, they are both struggling to get online consustently. Discussing it with a friend who is more tech savvy than me, he thinks that these cheap devices aren’t smart enough to deal with the availability of multiple APs, both being in range of two APs. The fire stick is actually located exactly in between two, though one (ie the UDR) is in the same room, whereas the other is on the floor above. Looking at the device settings within the Unifi app, there is in theory a way of forcing any device on the network to use only one specific AP:

4E324A05-0B00-4E2A-90A1-38C16BA9CFB0.thumb.jpeg.38e13ca817f8f40c27317eb7dfa001a1.jpeg

 

But in practice, when I try to enable “Lock to access point” it doesn’t fix the problem.

 

Googling around, it appears the solution for devices that don’t move around the house is to create a wifi network that is broadcast just from the AP closest to the device in question, and doing that for each problematic “stationary” device. Sounds like a bit of a faff, but I will try and implement that this weekend.

 

Link to comment
Share on other sites

Move it so that it just sees one of the APs to see if that fixes it. That way you’ll be sure you are chasing the right problem. I would have expected the Ubiquity hardware to manage this better though. I use three BT Wholehome Discs routed through a 4G TP-Link router connected to the Starlink router that’s just powering the dish rather than doing any routing. I contemplated swapping it all out for Ubiquity hardware but it’s quite dear so have stuck with my many box approach. It works well enough. 

Edited by Kelvin
Link to comment
Share on other sites

1 hour ago, Kelvin said:

Move it so that it just sees one of the APs

Or just turn the other APs off! A lot easier than walking around the house with a TV and Firestick. 😉

Link to comment
Share on other sites

4 minutes ago, Thorfun said:

Or just turn the other APs off! A lot easier than walking around the house with a TV and Firestick. 😉

I was actually having problems on all devices in the house I tested, including an iPhone XR and a pixel 3a and a computer connected only on wifi. Connectivity was erratic and VERY slow. So I unplugged the two APs so that the only wifi signal is coming from the Dream Machine. This has fixed the problem on the two phones and computer. But the ring doorbell is still showing -73dBm signal on the Unifi app and a “poor signal” on the ring app. This is an improvement compared to when the two APs were on as it showed “very poor signal” on the Ring app. 

Link to comment
Share on other sites

21 minutes ago, Dan F said:

UI EU store

This is where I have been looking. I’m after the switch lite 8PoE. That’s still out of stock. I’d consider getting the 16PoE version, but it’s out of stock too.

 

  • Like 1
Link to comment
Share on other sites

45 minutes ago, Thorfun said:

Or just turn the other APs off! A lot easier than walking around the house with a TV and Firestick. 😉

Indeed. Although most folk have more than one TV and the firestick will plug into a monitor. I had a similar problem with a Fire TV box. It worked everywhere in the house apart from the living room even though the wi-fi signal was strong in that room. I tried a firestick in the living room and that worked. 
 

 

Link to comment
Share on other sites

Fire stick still not managing to get online, despite only the dream router running and the Dream router being 4m from the fire stick, in the same room. I’ve reset everything. No solution. All a bit disappointing to be honest. So far this is proving more hassle than it should be.

Link to comment
Share on other sites

Is firestick failing to connect or failing to see internet once connected? It maybe that it does not offer the required level of security so cannot connect. In which case you can back off the security level for that devices MAC address to allow it in in your config if this is possible on your system, otherwise you may have to lower it for everybody and secure it all by MAC address or set up a VLAN for such devices.

Link to comment
Share on other sites

Posted (edited)

It sees the network, I try to connect, entering password, and then firestick just says connection error. I changed the security setting from WPA-3 to WPA-2/WPA-3, but this made no difference. I don’t think there is a lower security level. 

Edited by Adsibob
Link to comment
Share on other sites

3 hours ago, Adsibob said:

It sees the network, I try to connect, entering password, and then firestick just says connection error. I changed the security setting from WPA-3 to WPA-2/WPA-3, but this made no difference. I don’t think there is a lower security level. 

Switch your old wifi router on and look at the connection settings to see how it connects and if that works, should do as it used too, you might look at adding just the wifi point to the new network and see if you can get a connection. Also check that all the network protocols are active 802.11b etc. 

Link to comment
Share on other sites

This suggests the AP transmitter power might be the issue...

 

https://community.ui.com/questions/Connection-Problems-with-Amazon-Fire-TV-Stick/dd12a772-0d42-4761-9f10-ed73260015dc

 

Quote

 

Hi again,

today I had some time to try things out - seems I got it sorted out, and - seeing is believing! Didn't believe that too much transmission power might really play a role, but this really solved my problem. If I change power to "Auto" the Fire TV Stick gets ridiculously slow, showing "no network connection" each few minutes, changing to "Medium" gets everything up to 3 Mpbs - enough for TV.

 

 

I have also heard of an issue where the Firestick has an issue if there is 5GHz networks around...

 

https://community.spiceworks.com/topic/2313785-amazon-firestick-will-no-longer-connect-to-unifi-access-points
 

Quote

 

There is a problem in fire sticks with 5G WiFi. On your UniFi controller make sure the 5G only uses channels between 36 and about 44. The fire sticks have a manufacturing defect in their 5G WiFi chipset from the OEM and it is in hardware not correctable in firmware.

 

Quote

Check your 5G channels used by the AP’s must be 36-44 or create a 2.4g exclusive SSID just for firesticks. You can google the 5G WiFi flaw. I have (4) firesticks running on two AP’s fw v4.3.28.11nnn and v5.3.23 flex.

 

 

 

Are the 5GHz transmitters in the UDM and APs on by default? If not planning on using 5GHz you can probably turn off the 5GHz transmitter in the settings somewhere.

  • Like 1
Link to comment
Share on other sites

Posted (edited)

After a lot of tinkering, I think I’ve made progress. I manually got each of the 3 APs to use channel 1, 6 and 11 respectively on my main network so that they didn’t interfere with each other. I also created a 2.4ghz only network for the problematic devices.  Ring Doorbell still not getting a great signal, but it is working. Just kicking myself I didn’t get the PoE version Touch wood everything else seems to be working well…

let’s see how long it lasts.

Edited by Adsibob
Link to comment
Share on other sites

7 hours ago, Adsibob said:

Touch wood everything else seems to be working well…

let’s see how long it lasts.

Well done, you wonder why life has to get more complicated even though things are more complex using them should be simpler - very little is designed anymore just an extension of an extension with very little care for backwards compatibility (EG 5GHz).

Link to comment
Share on other sites

8 hours ago, Adsibob said:

Ring Doorbell still not getting a great signal, but it is working. Just kicking myself I didn’t get the PoE version

Glad you’re moving forwards. 
Is there a PoE Ring Video-doorbell? 

Link to comment
Share on other sites

10 hours ago, Adsibob said:

After a lot of tinkering, I think I’ve made progress. I manually got each of the 3 APs to use channel 1, 6 and 11 respectively on my main network so that they didn’t interfere with each other. I also created a 2.4ghz only network for the problematic devices.  Ring Doorbell still not getting a great signal, but it is working. Just kicking myself I didn’t get the PoE version Touch wood everything else seems to be working well…

let’s see how long it lasts.

They UI changes from version to version, but this is more or less what I've done: create a "legacy support" network SSID and put all the 802.11b devices on that. In fact I tend to put most devices on that and keep the "main" SSID just for higher bandwidth devices that have regularly updated software: phones, laptops, Chromecast, etc.

I've never had to mess about with manual channel assignment, across 5 APs.

(I also have a "guest" SSID that only has public internet access, and an "IoS" network for  IoT devices that only need local LAN access)

 

Link to comment
Share on other sites

On 05/08/2022 at 22:28, Adsibob said:

This is where I have been looking. I’m after the switch lite 8PoE. That’s still out of stock. I’d consider getting the 16PoE version, but it’s out of stock too.

I got the 16PoE switch eventually. It was out of stock a lot of the time I checked. 

 

I have a very similar setup to you with the two access points, fire stick, Chromecast and doorbell (Nest instead of Ring). The doorbell outside has the weakest signal of everything in the house but does work well. I also have two SSIDs with one for all the 2.4GHz stuff which includes the doorbell, Chromecast, firestick, washing machine and a lot of smart plugs. The other is both 5GHz and 2.4GHz and had laptops, phones, tablets, etc. 

Link to comment
Share on other sites

In the end, I just bought an unmanaged NetGear switch. I was a little overwhelmed by all the settings on the ubiquiti stuff I had bought, and the combination of wanting one less thing to manage, with the unavailability of the ubiquiti switches, were deciding factors.

Link to comment
Share on other sites

4 hours ago, Nickfromwales said:

Thanks. 
 

That price is just taking the piss tbh. 

Indeed! You would have thought the Ethernet version should be cheaper as less complexity, no need to make and supply a battery or wifi module. I had thought that maybe Ring were taking advantage of PoE being a relatively new technology, but Google tells me PoE has been around as a standard since 2003! So it’s just raw exploitation.

  • Like 1
Link to comment
Share on other sites

13 minutes ago, Nickfromwales said:

@Adsibob

A bit embarrassing for you, but I think you may have inadvertently created an avatar with BoJo and some clown makeup?

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

He's clearly a Muppet ;) 

Like the real BoJo, my avatar creation was very much deliberate. There is nothing accidental about this man. He plays the fool very well, but in reality he is an evil calculating sh!t.

  • Like 1
Link to comment
Share on other sites

8 minutes ago, Adsibob said:

Like the real BoJo, my avatar creation was very much deliberate. There is nothing accidental about this man. He plays the fool very well, but in reality he is an evil calculating sh!t.

I was a little frightened that you would hold back.

 

You go, sir!

 

He's as 'good' as the many sacks-o-shart that have gone before him.......

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...