Jump to content

Raspberry Pi WiFi


SteamyTea
 Share

Recommended Posts

I have 3 RPi Zero W.

Two happily connect, and stay connected to the wireless network, but one just keeps dropping out.  The only way I can restart the WiFi is to reboot.

This seems to be a known problem, but no definitive solution.

I have tried a batch file that pings one of the good RPi's address, but it drops out.  Tried a crontab command to stop and restart the wifi, if it has already dropped out, it don't reconnect.  Even put a line it to stop the power management turning off WiFi.

I have also tried most of the solutions online, and like most of the people that comment, it does not solve the problem.

So it may be a hardware problem and just getting a few new ones may solve it, but was hoping someone with a lot more networking experience knows the answer.

Link to comment
Share on other sites

I can't help directly, but I have a Pi dedicated to running Pi Music box mostly to stream internet radio. This is a hard ethernet connection not wifi.

 

It barely manages to stream something for 12 hours without stopping.  Sometimes you can log into it's user interface and re start the stream, other times it needs a re boot.  I already have it on a timer to give it a hard re boot every morning. 

 

I don't know if the root of my problem is slow and sometimes flakey broadband, or just buggy software.

Link to comment
Share on other sites

Just now, ProDave said:

This is a hard ethernet connection not wifi.

 

It barely manages to stream something for 12 hours without stopping.

Getting via ssh when on the USB to Serial always works (as it should).

 

1 minute ago, Adrian Walker said:

if i disabled Wireless Multimedia Extensions in my router the problem went away

I have read this, my network is my phone, or my neighbours WiFi, not sure how to turn it off on phone.

The unit I fitted @joe90's connected up right away after almost 18 months being left alone.  So I don't think it is a router problem.

Link to comment
Share on other sites

Google suggested..

 

Interference, fast roaming, or possibly inadequate power suppy..

https://community.ui.com/questions/Raspberry-Pi-Zero-W-keeps-disconnecting/5c6ec594-8f19-42e8-9802-dcea68289863

 

Possible work around.. reboot or just restart network..

https://weworkweplay.com/play/rebooting-the-raspberry-pi-when-it-loses-wireless-connection-wifi/

 

 

Link to comment
Share on other sites

They're somewhat variable from board to board. Maybe subtle differences in layout between issues? Anyway, been there, fixed that. I think that the instabilities are arising from dynamic changes in clock speed. This can be fixed by forcing on turbo mode by adding the following line to the /boot/config.txt file:

force_turbo=1

Another tweak some people swear by is raising the default core voltage with:

over_voltage=2
 

I think it's safe but unnecessary. YMMV

  • Like 1
Link to comment
Share on other sites

32 minutes ago, Radian said:

They're somewhat variable from board to board. Maybe subtle differences in layout between issues? Anyway, been there, fixed that. I think that the instabilities are arising from dynamic changes in clock speed. This can be fixed by forcing on turbo mode by adding the following line to the /boot/config.txt file:

Interesting suggestion.  I have implemented that on my Music box, I will let you know if it keeps a connection any longer.

Link to comment
Share on other sites

8 hours ago, MJNewton said:

Are there any clues reported in /var/log/syslog, /var/log/messages or /var/log/kern.log?

Possibly, but there are so many words in them, I would need to print them out.

 

8 hours ago, Radian said:

 I think that the instabilities are arising from dynamic changes in clock speed

Giving it a go now, it usually drops off the network within half an hour.

Link to comment
Share on other sites

1 hour ago, SteamyTea said:

@Radian and @ProDave

And anyone else that has had this problem.

 

So far it has been stable.

Just got to find the loose wire to the sensors now (but that is one the RPi that was stable).

Mine usually works for a few hours before losing connection.  If it lasts to the end of today then I will remove the "morning re boot" timer and see how long it holds up.

Link to comment
Share on other sites

Posted (edited)
17 minutes ago, ProDave said:

Mine usually works for a few hours before losing connection.  If it lasts to the end of today then I will remove the "morning re boot" timer and see how long it holds up.

Mine is still going, 2 hours now.  It was still logging the data OK, just the WiFi was dropping out.

I made the same changes to the other logger I have, the one with the wobbly wire (though I could not see a problem and it was working fine before I moved it), and that seems to be logging OK now.  Logging started at 02/03/2022 07:11:22, and now it is 02/03/2022 08:51:03.

 

Purely for scientific interest, my wall probe has shown a rise in temperature from 9.9°C to 10.1°C, and the OAT is 9.5°C and 9.7°C.  So the wall temp seems to be tracking the OAT temp nicely (a good thing).

 

Off for a hunt for diesel now, I may be some time.

Edited by SteamyTea
Link to comment
Share on other sites

16 minutes ago, SteamyTea said:

Purely for scientific interest, my wall probe has shown a rise in temperature from 9.9°C to 10.1°C, and the OAT is 9.5°C and 9.7°C.  So the wall temp seems to be tracking the OAT temp nicely (a good thing).

 

Ah, so you're running that experiment... I'd be interested in what happens in various weather conditions.

Link to comment
Share on other sites

30 minutes ago, Radian said:

 

Ah, so you're running that experiment... I'd be interested in what happens in various weather conditions.

Me to. It is a no weather day today.

And a no diesel one by the looks of it.

Link to comment
Share on other sites

I have fitted the unit now, but have just tried to remotely log in, after an hour of it being in place, and it has not done it.

A proper reboot (pulling the plug) has allowed me to connect, and the data was still being collected.

Shall look at it later as there will be nothing else to do tonight.

Link to comment
Share on other sites

Well I managed to log in this morning no problems, so maybe just a glitch.

If it happens again, I shall up the voltage 1 unit (0.025V).

 

I am not hoping to get some weather to see what is happening, though this is a long term project.

Link to comment
Share on other sites

Mine stayed connected for almost 24 hours until the morning reboot timer turned it off, so I have removed the reboot timer and see how long it keeps going

Link to comment
Share on other sites

27 minutes ago, ProDave said:

Mine stayed connected for almost 24 hours until the morning reboot timer turned it off, so I have removed the reboot timer and see how long it keeps going

Good stuff.

Mine disconnecting may just have been an issue from moving it to the front of the house and then giggling it about as I tried to make room for it on a table.

Quick check just now and it is fine.

image.png.a2b60cb0c24e402558556eb377f96ce0.png

Link to comment
Share on other sites

Glad it seems to be working. I have two of the first generation of RaspberryPi zero's configured as security cameras. Both need force_turbo enabled to make them stable. I don't recall having to do this with more recent iterations, inclding zerow versions.

Link to comment
Share on other sites

8 minutes ago, Radian said:

Glad it seems to be working. I have two of the first generation of RaspberryPi zero's configured as security cameras. Both need force_turbo enabled to make them stable. I don't recall having to do this with more recent iterations, inclding zerow versions.

That would make sense.  I originally bought this Pi in about 2012 so one of the early ones, initially intending to use it for my solar PV dump controller but decided an Arduino would be a simpler device for that job.  It was only about 2 years ago I blew the dust of this old Pi and put it into use.

Link to comment
Share on other sites

Mine has been running nearly 3 days now without dropping the connection or needing a re boot, so it looks like it has solved the problem.

 

Well done buildhub again.

Link to comment
Share on other sites

2 hours ago, ProDave said:

Mine has been running nearly 3 days now without dropping the connection or needing a re boot, so it looks like it has solved the problem.

Not had a problem either (except that once, which was probably my fault).

 

May have to play about and see if it is the CPU speed or the Core Voltage that is the true key to the problem.

 

Link to comment
Share on other sites

5 minutes ago, SteamyTea said:

May have to play about and see if it is the CPU speed or the Core Voltage that is the true key to the problem.

 

The optimum core voltage has a slightly complicated relationship with the clock speed. To maintain a sensible level of dissipation the voltage really needs to be reduced when the clock speed is increased. But this works against the need for a higher core voltage to keep rise times within stability bounds. I'm reasonably convinced that it is the adaptive change in clock speed that throws the processor as it switches from one speed to another. Enabling force turbo mode ensures that the clock speed is fixed. If there was an option to fix any other clock speed I think this would have the same effect.

 

The only possible benefit of altering Vcore is to bring rise times into spec for higher speeds. The default value should be adequate for all the speeds including turbo. It is only that there will be additional dissipation when force turbo is enabled. If stability could be maintained with a lower Vcore then this may be worth doing.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...